Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Here's a statement of the obvious: The opinions expressed here are those of the participants, not those of the Mutual Fund Observer. We cannot vouch for the accuracy or appropriateness of any of it, though we do encourage civility and good humor.

    Support MFO

  • Donate through PayPal

request for assistance: page distortions

Dear friends,

Chip and I are trying to puzzle through two emails we received from readers complaining the MFO was blank when they tried checking in during the last day or two. One reader (using Firefox 3.5) said that all of the text was pushed off the side of the screen, leaving the body of the screen blank. I suggested updating to the current Firefox 20, if only for security's sake. The other reported that only the top banner was visible and the rest was blank. He was running Chrome on an Apple machine.

We did not make changes in the underlying software on the first, though there was a WordPress update a couple weeks ago. Chip has been running diagnostics (there are programs that run your site through up to 150 browsers at once to see if it's compatible) but hasn't discovered anything.

Here's the request: if you've experienced any unusual symptoms, please drop me a note and let me know what and when. Chip will monitor the thread to see if she can find a pattern. I'll also send a version of this note to the folks on the conference call mailing list, asking them to glance in if they haven't already.

That said, Monday was our biggest single day ever - 2900 folks dropped by to read the April issue and join in the discussion board. It's possible, though improbable, that that was sufficient volume to cause the occasional hiccup. The Pingdom monitors shows 100% site availability since the day last week with the 22 minute outage.

Thanks, as ever, for your support and willingness to help out.



  • edited April 2013
    I have experienced this white page issue when trying to open individual threads on the discussion board, but only with my NOOK. Never with my laptop, which uses FireFox 19. And never with my iPhone. It usually happens when I am trying to open one of Scott's threads, which tend to be chock full of info! But, mostly, I blame my browser-challenged NOOK.
  • Such page distortions are typically due to browser not receiving the full page data and TCP connection is closed prematurely. Depending on the amount of info received browser tries to decode incomplete HTML code and the result is often less than desired. It could be the host is having network problems or overloaded that OS is terminating server processes prematurely. It could also be a faulty network interface card on the server etc. Too many stuff to diagnose remotely. If possible you can ask your hosting company to move MFO to a different server on their server farm. See if that helps.
  • edited April 2013
    Investor is correct about the browser aberrations.

    Where do they have problems - viewing wordpress blog, or reading the forum??

    On the user side:

    Have you asked the users who report problems - what type of connection they are using wireless from a coffeeshop, dialup, or cable, etc., etc.

    Do their computers run updates of software in the background.

    On the server side:

    Do You have a neighbour on your database server that's overloading it. How is this allocated with your provider?
    Do you have enough resources on your database server to handle the forum.

    Personally - I don't see a problem with viewing the forum.

    I think you will be chasing this till the end of time and never find an answer,

    maybe if more people see a consistent problem, especially people who know what is going on with their own computer, and have up to date browsers.
  • David, A long time ago I reported similar behavior with IE 8:
    Someone (deleted user) suggested I use the old link eliminating the banner:
    So I use the link above to link MFO. This problem only occurs on one setting however - my favorite brower setting and so when MikeM had a problem with Kindle Fire, I suggested he try changing text size. He did and it apparently helped:

    The behavior is similar though with the same right size of screen text effect. At the time I reported it, I was the only one with a problem and IE 8 was going out of common use so it didn't seem like a big problem. Are IE 8, Kindle, and the current problems due to the same problem? The fact that the number of browsers is increasing with time seems to point to something that is being added to the browsers and not to MFO but it's hard to know. Or is it something to do with the banner? Has it changed lately or the way that it loads changed?
  • David, One other thing about my settings. I have IE 8 accessibility options set to "Ignore font sizes specified on webpages". Again, only when my text size (under the menu item view) is set to "Larger" or "Largest" does the problem appear. If I turn the "Ignore font sizes ..." off, the page (with banner) loads correctly. Alternately, if "Ignore font sizes ..." is on, the page loads with font sizes "Medium" and smaller.
  • Browser ! Browser! Problems Everywhere, but guess what I no longer care.
  • Reply to @Ted: Yea, I've just lived with it since I have a good solution. Are you one of the ones that recently reported a problem? If so, are you saying that you no longer care if your particular situation is solved?
  • Reply to @Anna: When I use IE browser, I can link a couple of articles then I must log-off line before I can link any more articles. I can't log on MFO when using Firefox, it doesn't recognize my username and password. Therefore I forced to use Chrome.
  • I had a blank screen on the Discussion Board using SeaMonkey (which is basically FireFox) and had a problem for the whole site last month. I am at a hard-wired computer but plenty of stuff running concurrently. Chrome seems to work fine.
  • Reply to @Ted:
    I can't log on MFO when using Firefox, it doesn't recognize my username and password.
    Hi Ted,

    I only use Firefox and have no problem logging in and out of MFO. There must be some setting in your Firefox that is preventing you, but I can't imagine which one.

  • Reply to @Mona: I just had to switch from IE to Chrome so I could reply to your message. There is nothing wrong with my Firefox after trying several things to correct the problem. The problem lies with MFO and all the bells and whistles the IT people have convinced David he needs. MFO needs to get it's own server and get rid of all the unnecessary add-on's that don't bring people to the MFO Board.
  • edited April 2013
    Reply to @Ted: I use Firefox all the time. No problem. Really the problems you are seeing with Firefox seems to be unique to your computer. Perhaps you have a toolbar or plugin installed, redirecting your interaction with this site through a 3rd party site or interfering with your normal operation. Or some sort of anti-virus, firewall etc. is interfering. Whatever it is there is something wrong with your setup.
  • edited April 2013
    Reply to @Investor:

    >Whatever it is there is something wrong with your setup.
    exactly and nothing to do with bells and whistles.

    Ted, should uninstall firefox completely from his system, and re-install. If he is interested in solving his problem. But it might take some convincin'.

    However, I a lot of problems would most likely go away, if the forum wasn't embedded and just had links to the wordpress blog. But that too, would take a lot of convincing.
  • Reply to @Anna:
    I run MFO on Firefox with no problem, unless I have the zoom setting set too high on the No Squint app.
  • So far, Anna's theory that the problems might have to do with the rendering of the fonts (and font sizes) under various browsers seems to be valid. If you're experiencing problems with pages not loading correctly, please try adjusting the font size or settings in your browser to see if that helps.

    Thanks for all your feedback.
  • Reply to @Ginko: I have a feeling that it has something to do with the automatic scaling (I hope that makes sense). It seems to me that the first character placed on the page after the banner main menu (Home About (etc.) is mapped is not finding enough room at the top of the character or the submenu textbox when the character is too large/tall. Something in the scaling might move it off to the right as it looks for a place to put the text where it will fit on that first line. That is what it looks like on my computer when I use the link to list the discussions. What happens on my computer is that the header tries to load and ends up wrapping around leaving two vertical lines on the left of the page in the text area. If I mouse-over these lines the "Support Us!" button appears when the mouse is between the two lines. The blue submenu "Discussions Inbox (etc)" does not appear. (So the vertical lines and distance between them are the size of a button after it has scaled to the larger text size, wrapped around and eaten the submenu. But this does put it below the menu area into the text area. When this happens I get a blank text page but I have demonstrated to myself that the text has gone off the text area to the right.

    That is why I think that the scaling, when this occurs, is readjusting the page to an empty area which just happens to be out of bounds. I could be very wrong but I can't test it nor can all of us send our individual computers with the settings that cause it to Chip to study.

    I'm using XP so I would either need to move to another browser or buy another computer to fix it. But, in my case, the solution is so easy and smooth (don't load the banner) that as long as the option exists I don't even think about it.
  • Reply to @chip: Looks like we were typing at the same time. See my message to Ginko above.
  • edited April 2013
    Reply to @Anna:

    @Chip and @Anna

    Two things. Anna. Can you post a link to an image (or send it to chip and she can post it) with the area circled in red where you think the problem occurs.

    Also I could look into changing the font size specifically for you when you log on to the forum, if that would be ok with chip.

    Let me know both of you if you want to test and when. also if you could include an image of what forum details you want enlarged and what font size
  • Reply to @Accipiter: I don't need it fixed just for me. I was providing the information in case it might help Chip figure out the other cases. If my problem is not related there is no reason to pursue and fix it because I am using XP IE8 and have the options set to ignore the font size of the MFO site in favor of my own large font settings. I leave this setting that way all the time so I don't think Chip should waste time trying to reset my font alone if it is unrelated to other's problems. The chances of another computer having my weird combination of operating system, browser and accessibility settings are almost nil. I have my own work around that I use for my computer. I just use an old way of linking that didn't load the banner stuff. I can get screen shots if they are still needed for other computers. Let me know if that is the case.
  • edited April 2013
    Reply to @Anna:

    I don't really need the screenshots unless chip wants me to change something. I view the same way you do unembedded - faster on slow connections and all I have to do is click home to get to the blog and more viewing area.
Sign In or Register to comment.